Subaru VSS to Alpha-Pro

Posts regarding the Road Rally (TSD) participants.

Re: Subaru VSS to Alpha-Pro

Postby TeamHarco » Tue Oct 24, 2017 11:20 am

Jim White wrote:
TeamHarco wrote:Not to be a jerk, though I play one on TV...


Scott, what TV show? I'd just like to check and see if you act it any better than you do it in person:-)

A) I don't happen to have the magnets or a bracket or ... on hand (and I'd have to get my hands dirty).
B) I enjoy playing with electronics.
C) The ease of clipping a connector onto a VSS wire for the last 3 or 4 Subaru's and having the odometer just work has been a real treat.
D) I already have a functional EZ-Pulse that I can finagle onto a wheel to provide odo pulses should I not get direct car electronics working.
E) I know a rallyiest who had magnets (maybe not quite well mounted?) who had rallied for a couple years with them before rounding a tight corner at speed and encountering a surprise pothole that neatly got just the right flex to strip all 4 magnets off.
F) An ODB plug in would be a real boon (and suit taxi, nav systems, highway maintenance vehicles, occasional cop cars, etc., witness all the after-market devices). But I don't believe ODB or CAN have a suitable signal (bummer).
G) I've had "factory trained" mechanics modify prior device installations where undoing the nuts and swapping the (mis)reinstalled parts after a repair was deemed too difficult so they simply took a hacksaw to the long side to gain the clearance needed.

But, yes, magnets are still an option.


Jim,

Not an actual show. I just climb on the TV and act like a jerk.* No different than what most people experience of me, in person.

A) Not hard to find. You just have to shell out a little cash. Can't help with the dirty hands, but there is - soap.
B/C) I figured you enjoyed playing with electronics. And yes - there is a lot to be said for simply finding a good source of a good pulse and using it. But - as you are finding out, this particular car is not cooperating.
D/E) The E-Z pulse is a reasonable fallback/ reserve/ fly-in and attach to a rent-a-car solution. It is much less robust than well located and mounted magnets. I've rallied with magnets on axle shafts and senders for close to 30 years. No loss of magnets in all that time. I have had a sender fail (discovered after driving all the way to Wisconsin and then having to run S). And at last year's LSPR, we were looking for a short-cut to get to the next spectating area, effectively off-roading, tore off the wire to a sender. Discovered and repaired in plenty of time for the next rally we needed it (plus it was back-up to the primary). I have always run at least two on each of my cars since the Wisconsin incident.
F) Yep - a simple plug-in at the OBD port would be nice.
G) Yep - another reason I do not visit a dealer or a repair shop. If I can't fix it - it's time for the scrap yard, or it becomes a parts car. Granted, not many people can do that. But a robust magnet set-up is hard to beat.

You play with electronics. I play with mechanical things. The world needs engineers.

Let me know if you need some tips on a magnet installation. I could reveal some of my secrets (as long as you promise not to pass them on). ;)

* Like the penguin...
https://www.youtube.com/watch?v=EyFxXdqtGNk
Scott
Team Harco Motorsports
"Win on Sunday, Sleep on Monday"
User avatar
TeamHarco
 
Posts: 25
Joined: Wed Dec 14, 2016 7:38 am

Re: Subaru VSS to Alpha-Pro

Postby Jim White » Wed Oct 25, 2017 6:54 pm

Continuing to poke at it there really is nothing labeled "VSS" on the "newer" Subarus and the signals coming off the transmission where the old VSS came off aren't clean square waves as shown on the prior oscilloscope traces. But I've now located a "vehicle speed output signal" line off of the Vehicle Dynamics Control. The documentation says it's a 0-12 volt pulse signal but my testing shows a 0-4.4 volt square wave signal (see image). The 4.4 volts is about the same as the 4.5 documented for the CAN bus though less than the signals off of the transmission speed signals. In testing so far the signal seems very clean and consistent and seems to work the Alpha-Pro very well. The major difference between it and the old VSS is that it ticks twice as fast, a tick about every 1.2 feet. Since my road test was only to 55 MPH I'll have to do some more testing to be sure I won't have to divide the signal pulses by two but things are looking pretty good at the moment. For anyone reading this my car is a 2013 Subaru Outback and I attached to the signal wire where it comes off of the connector to the VDC under the hood. Pin 11, green with black stripe (GB) wire. On my car I also note that there are molded-in pin numbers on the VDC side that the connector plugs into but the numbers are in the opposite columns compared to the numbers in the documentation so the molded-in label says 24. The GB wire ultimately, through several connectors, feeds into the speedometer/odometer on the dash. The only conditioning I've done so far is put a diode that my old Subaru's VSSs required to connect to the Alpha-Pro in the line but backwards from what was required on the old setup. I'm going to study that issue some more. Anyway I should be ready for the next POR without fussing with magnets.
Attachments
jj1_40_sm.png
Vehicle speed output signal at 40 MPH.
jj1_40_sm.png (264.6 KiB) Viewed 46 times
Jim White
Jim White
 
Posts: 9
Joined: Wed Aug 16, 2017 5:59 pm

Re: Subaru VSS to Alpha-Pro

Postby Jim White » Sun Nov 05, 2017 6:10 pm

Just a further update. Testing at speeds up to 70 MPH continuous over 10 miles of interstate show that the "vehicle speed output signal" works reliably on my Alpha-Pro. I was getting errors in 10 miles of plus or minus .003-4 miles which is very reasonable and easily accounted for by slightly different cornering paths and weaving for traffic. At this point I'm assuming that the diode does nothing particularly useful but it doesn't interfere either though it does drop the signal a touch over .3 volts. If time permits I may do an optoisolator and maybe a selectable divider just for fun but I think I'm ready to rally. Thanks to all for the input.
Jim White
Jim White
 
Posts: 9
Joined: Wed Aug 16, 2017 5:59 pm

Previous

Return to Road Rally

Who is online

Users browsing this forum: No registered users and 1 guest
cron